Skip to main content
VulnerabilityPublished Updated

CVE-2025-13081: Drupal core · Mass Assignment

Affects Drupal coreSource CVE Database V5

0

Not known to be exploited · CVSS 5.9 Medium · fixed in 11.2.8 : update Drupal core when convenient.

Data as of 26 Oct 2026, 09:08 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.2.8, 11.1.9, 10.5.6 +1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade drupal/core to 11.2.8, 11.1.9, 10.5.6 or 10.4.9.

Affected software

ProductAffectedFixed in
Packagistdrupal/corepkg:composer/drupal/coreOther threatsAffected
  • =8.0.0
  • <10.4.9
  • >=10.5.0
  • <10.5.6
  • >=11.0.0
  • <11.1.9
  • >=11.2.0
  • <11.2.8
Fixed in
  • 10.4.9
  • 10.5.6
  • 11.1.9
  • 11.2.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately identify and inventory all Drupal core instances in your environment, noting versions to determine exposure. 2. Apply official Drupal security patches or upgrade to the fixed versions: at least 10.4.9, 10.5.6, 11.1.9, or 11.2.8 and above as applicable. 3. Restrict administrative access to trusted personnel and enforce strong authentication mechanisms such as multi-factor authentication (MFA) to reduce the risk of privilege misuse. 4. Monitor logs and audit trails for unusual administrative activity or object attribute modifications that could indicate exploitation attempts. 5. Implement strict access controls and segmentation to limit the impact of compromised administrative accounts. 6. Regularly review and harden Drupal configurations to minimize attack surface, including disabling unnecessary modules and features that may increase risk. 7. Stay informed via official Drupal security advisories and community channels for updates or emerging exploit reports. 8. Conduct security assessments and penetration testing focusing on object injection and privilege escalation vectors within Drupal environments. 9. Educate administrators on secure handling of credentials and recognizing phishing or social engineering attempts that could lead to privilege compromise.

Description

Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection.This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8.

References

Community reviews

Loading reviews…