Skip to main content
VulnerabilityPublished Updated

CVE-2026-63887: Linux kernel · scsi: target: iscsi: Bound iscsi_encode_text_output() appends to rsp_buf

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-63887· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · fixed in 5.15.0-1116.123~20.04.1 : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1116.123~20.04.1, 5.15.0-1122.131~20.04.1, 5.15.0-1121.130~20.04.1 +69
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-28.28
Fixed in
  • 7.0.0-28.28
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1010.10
Fixed in
  • 7.0.0-1010.10
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.8
Fixed in
  • 7.0.0-1008.8
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1003.4
Fixed in
  • 7.0.0-1003.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available and should be applied to affected Linux kernel versions. The patch adds proper bounds checking to prevent heap overruns and improves error reporting to initiators. Systems running affected kernel versions should be updated promptly to incorporate this fix. No additional mitigations are specified by the vendor advisory.

Description

A heap buffer overflow vulnerability was resolved in the Linux kernel's iSCSI target subsystem. The vulnerability arises from iscsi_encode_text_output() appending key=value records into a fixed-size buffer without proper bounds checking, allowing up to 32 KiB of output into an 8 KiB buffer. This results in a heap overrun of approximately 24 KiB. The fix adds proper bounds checking and error handling to prevent buffer overflow and ensures the initiator receives an explicit failed-login response on overflow.

References

Community reviews

Loading reviews…