CVE-2026-63908: Linux kernel · Input: atmel_mxt_ts – fix boundary check in mxt_prepare_cfg_mem
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 5.15.0-1117.124~20.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1117.124~20.04.1, 5.15.0-1123.132~20.04.1, 5.15.0-1122.131~20.04.1 +65
Exploitation evidence
Disclosed: evidence found.
CVE published 20 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied through standard system updates to the Linux kernel linux-aws packages. Users should update to versions 7.0.0-28.28~24.04.1 or later where the boundary check issue is fixed. No additional mitigation is indicated by the vendor advisory.
Description
A boundary check vulnerability in the Linux kernel's atmel_mxt_ts driver allowed writing one byte beyond the intended memory boundary when processing configuration data. This flaw could lead to adjacent memory corruption. The issue affects multiple linux-aws kernel versions prior to 7.0.0-28.28~24.04.1 and related versions. A patch correcting the boundary condition is available and should be applied via standard system updates.
References
- nvd.nist.gov/vuln/detail/CVE-2026-63908 (opens in a new tab)
- git.kernel.org/stable/c/1017e1c6c6c49cccbcda9bbcfa49e50b0b6dad39 (opens in a new tab)
- git.kernel.org/stable/c/5c3681c3abc35cfac6b702251382312c60d96bc2 (opens in a new tab)
- git.kernel.org/stable/c/6c6b989b4ebf22b086fdfcac2163b5cb55e34d8f (opens in a new tab)
- git.kernel.org/stable/c/7f95f4792c0dc767fcb8e405391e779ab419d55a (opens in a new tab)
- git.kernel.org/stable/c/862a1a32b5190241fce7a7d20229539a3926f31e (opens in a new tab)
- git.kernel.org/stable/c/ae92e334544263a02d9f99e18385e718c44392c9 (opens in a new tab)
- git.kernel.org/stable/c/baa0210fb6a9dc3882509a9411b6d284d88fe30e (opens in a new tab)
- git.kernel.org/stable/c/e9b62996ba537774f68fecfd7eecb5aec1713952 (opens in a new tab)
- ubuntu.com/security/CVE-2026-63908 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-63908 (opens in a new tab)
- git.kernel.org/linus/baa0210fb6a9dc3882509a9411b6d284d88fe30e (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8878-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8879-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8877-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8875-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8903-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8905-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8906-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8904-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8903-2 (opens in a new tab)