CVE-2026-64106: Linux kernel · KVM: arm64: vgic-its: Reject restored DTE with out-of-range num_eventid_bits
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 9.0 Critical · fixed in 6.8.0-1064.67~22.04.1 : patch Linux kernel as a priority.
Data as of 28 Oct 2026, 12:05 UTC
- Patch
- Available – fixed in 6.8.0-1064.67~22.04.1, 6.8.0-1067.75~22.04.1, 6.8.0-1065.72~22.04.1 +41
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8729-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8761-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8729-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8761-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8781-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8729-3 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in Linux kernel versions 6.8.0-1064.67~22.04.1 and later. Users should update to these fixed kernel versions or later to remediate this vulnerability. No additional mitigation actions are required beyond applying the official fix.
Description
CVE-2026-64106 is a critical vulnerability in the Linux kernel's KVM arm64 vgic-its component. It involves improper validation when restoring an ITS Device Table Entry (DTE) with an out-of-range num_eventid_bits value. This flaw allows userspace to restore a DTE whose Size field encodes more EventID bits than supported by the virtual ITS, potentially leading to system instability or denial of service. The issue has been fixed by rejecting restored DTEs with num_eventid_bits exceeding the allowed limit before device allocation.
References
- ubuntu.com/security/CVE-2026-64106 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-64106 (opens in a new tab)
- git.kernel.org/linus/9ce754ed8e7ab4e3999767ce1505f85c449ccb07 (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8729-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8761-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8729-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8761-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8781-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8729-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8761-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8802-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8729-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8729-5 (opens in a new tab)