CVE-2026-64176: Linux kernel · wifi: iwlwifi: mvm: fix driver-set TX rates on old devices
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 8.1 High · fixed in fb84b5cbcaab3ca0f4e961d92a40ed7f3aac483b : patch Linux kernel soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in fb84b5cbcaab3ca0f4e961d92a40ed7f3aac483b, 6fe92651b44fd3cfc8dcfdaad0e82885c384dada, 6b58a79f2cd98156856eb49e8b55db5facdd7e6d +1
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Linux to fb84b5cbcaab3ca0f4e961d92a40ed7f3aac483b, 6fe92651b44fd3cfc8dcfdaad0e82885c384dada, 6b58a79f2cd98156856eb49e8b55db5facdd7e6d or 6.18.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| LinuxLinux | Affected
| Fixed in
|
| LinuxLinux | Affected
| Fixed in– |
AI-suggested
A patch is available and should be applied by updating the Linux kernel to the fixed versions provided by the vendor. For Ubuntu 26.04 LTS, update to kernel versions 7.0.0-1008.8 or later as specified in the advisory. After updating, a system reboot is required. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary. Follow the vendor's update instructions carefully to ensure full remediation.
Description
A vulnerability in the Linux kernel's iwlwifi driver for certain older Wi-Fi devices was fixed. The issue involved incorrect handling of transmission (TX) rates due to changes in rate encoding formats, which could cause the driver to set TX rates improperly, potentially leading to device warnings or crashes. This flaw affected older devices such as the 7265D model. The vulnerability has a CVSS score of 8.1, indicating high confidentiality impact and high availability impact but no integrity impact. A patch is available and included in updated Linux kernel packages for Ubuntu 26.04 LTS and related releases.
References
- nvd.nist.gov/vuln/detail/CVE-2026-64176 (opens in a new tab)
- git.kernel.org/stable/c/6b58a79f2cd98156856eb49e8b55db5facdd7e6d (opens in a new tab)
- git.kernel.org/stable/c/6fe92651b44fd3cfc8dcfdaad0e82885c384dada (opens in a new tab)
- git.kernel.org/stable/c/fb84b5cbcaab3ca0f4e961d92a40ed7f3aac483b (opens in a new tab)
- ubuntu.com/security/CVE-2026-64176 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-64176 (opens in a new tab)
- git.kernel.org/linus/fb84b5cbcaab3ca0f4e961d92a40ed7f3aac483b (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)