Skip to main content
VulnerabilityPublished Updated

CVE-2026-64289: Linux kernel · iommufd: Set upper bounds on cache invalidation

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · CVSS 5.5 Medium · fixed in 6.8.0-147.147 : update Linux kernel when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-147.147, 6.8.0-1067.70, 7.0.0-1012.12~24.04.1 +28
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-31.31
Fixed in
  • 7.0.0-31.31
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1012.12
Fixed in
  • 7.0.0-1012.12
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1013.13
Fixed in
  • 7.0.0-1013.13
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1011.11
Fixed in
  • 7.0.0-1011.11
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.7
Fixed in
  • 7.0.0-1006.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been applied in Linux kernel versions 6.8.0-147.147, 6.8.0-1067.70, 7.0.0-1012.12~24.04.1, and other related fixed versions. Users and administrators should update to these fixed kernel versions to mitigate the vulnerability. No additional mitigation actions are required beyond applying the official kernel updates.

Description

CVE-2026-64289 is a vulnerability in the Linux kernel's iommufd component where user-controlled parameters for cache invalidation were not properly bounded, allowing excessive resource consumption leading to CPU soft-lockups. The flaw involves unbounded entry_num and entry_len values in the iommufd_hwpt_invalidate() function, which can cause the kernel to perform long, uninterruptible operations. This issue has been fixed by imposing upper bounds on these parameters to prevent excessive processing.

References

Community reviews

Loading reviews…