CVE-2026-6486: classroombookings · Cross-site Scripting
Affects classroombookingsSource CVE Database V5
Public exploit available · CVSS 5.1 Medium · fixed in 2.17.1 : patch classroombookings as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.17.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 17 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| classroombookings | Affected
| Fixed in– |
GitHubclassroombookings/classroombookingspkg:github/classroombookings/classroombookingsOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:classroombookings:classroombookings:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A vendor-provided official fix is available in classroombookings version 2.17.1. Users should upgrade to this version to remediate the vulnerability. Since the vendor has released a fixed version promptly, applying this update is the recommended and sufficient mitigation. Patch status is confirmed by the vendor advisory and the provided patch commit identifier.
Description
A vulnerability was detected in classroombookings up to 2.17.0. This impacts the function read of the file crbs-core/application/views/layout.php of the component User Display Name Handler. The manipulation of the argument displayname results in cross site scripting. The attack can be executed remotely. The exploit is now public and may be used. Upgrading to version 2.17.1 will fix this issue. The patch is identified as 69c3c9bb8a17f1ea572d8f4502bf238f0214c98a. It is suggested to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
References
- vuldb.com/vuln/358027 (opens in a new tab)
- vuldb.com/vuln/358027/cti (opens in a new tab)
- vuldb.com/submit/786154 (opens in a new tab)
- github.com/sudo-secure/security-research/blob/main/classroombookings/stored-xss/PoC.md (opens in a new tab)
- github.com/classroombookings/classroombookings/pull/83 (opens in a new tab)
- github.com/classroombookings/classroombookings/commit/69c3c9bb8a17f1ea572d8f4502bf238f0214c98a (opens in a new tab)
- github.com/classroombookings/classroombookings/releases/tag/v2.17.1 (opens in a new tab)
- github.com/classroombookings/classroombookings/ (opens in a new tab)