Skip to main content
VulnerabilityPublished

CVE-2026-65432: Apache CXF · XML External Entity (XXE)

Affects Apache CXFSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 4.2.3 : patch Apache CXF soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.3, 4.1.8, 3.6.12
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Apache to 4.2.3, 4.1.8 or 3.6.12.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache CXFAffected
  • >=4.2.0 <4.2.3
Fixed in
  • 4.2.3
Apache Software FoundationApache CXFAffected
  • >=4.0.0 <4.1.8
Fixed in
  • 4.1.8
Apache Software FoundationApache CXFAffected
  • <3.6.12
Fixed in
  • 3.6.12
MavenApache Software Foundation/org.apache.cxf:cxf-rt-wsdlpkg:maven/Apache Software Foundation/org.apache.cxf:cxf-rt-wsdlOther threatsAffected
  • >=4.2.0 <4.2.3
  • >=4.0.0 <4.1.8
  • <3.6.12
Fixed in
  • 4.2.3
  • 4.1.8
  • 3.6.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache CXF to versions 4.2.3, 4.1.8, or 3.6.12, which include fixes for this vulnerability. No other mitigations are specified. Patch status is confirmed by the vendor advisory recommending these versions.

Description

Apache CXF versions prior to 4.2.3, 4.1.8, and 3.6.12 are vulnerable to an XML External Entity (XXE) attack due to improper restriction of XML external entity references in imported WSDL/XSD documents. While the top-level WSDL is processed securely with external entities disabled, imported documents are handled by WSDL4J, which does not disable these features, exposing the system to potential information disclosure. This vulnerability is identified as CWE-611 and has a CVSS score of 7.5, indicating high severity. Users are advised to upgrade to fixed versions 4.2.3, 4.1.8, or 3.6.12 to mitigate the risk.

References

Community reviews

Loading reviews…