Skip to main content
VulnerabilityPublished

CVE-2026-66293: qcam saxy · XML Injection

Affects qcam saxySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.1 Low : upgrade to 1.7.0 when convenient.

Data as of 6 Nov 2026, 10:48 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (EEF)CVSS 4.02.1
Patch
Available – fixed in 1.7.0, 6d12ee12b9e32e86ef598b3f3cafccd1840b2f41
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade saxy to 1.7.0; saxy to 6d12ee12b9e32e86ef598b3f3cafccd1840b2f41.

Affected software

ProductAffectedFixed in
qcamsaxyAffected
  • >=0.7.0 <1.7.0
Fixed in
  • 1.7.0
saxyqcam/saxyAffected
  • ≥ 7266632e9407842f28ffac254c56dc41210a5690, < 6d12ee12b9e32e86ef598b3f3cafccd1840b2f41
Fixed in
  • 6d12ee12b9e32e86ef598b3f3cafccd1840b2f41
Hexsaxypkg:hex/saxyOther threatsAffected
  • >=0.7.0 <1.7.0
Fixed in
  • 1.7.0

CPE configurations (1)

  • cpe:2.3:a:qcam:saxy:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to saxy version 1.7.0 or later, where this vulnerability is fixed.

Description

CVE-2026-66293 is an XML injection vulnerability in the Saxy encoder component of the qcam saxy library. The encoder fails to properly neutralize the '--' sequence within XML comment content, allowing an attacker to prematurely close comments and inject arbitrary sibling markup. This can lead to stored cross-site scripting (XSS) when rendered as HTML or SVG, or data forgery when processed by other XML consumers. The vulnerability affects saxy versions from 0.7.0 up to but not including 1.7.0. A fix is available starting from version 1.7.0.

References

Community reviews

Loading reviews…