CVE-2026-6637: PostgreSQL · Stack-based Buffer Overflow
Affects PostgreSQLSource CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 18.4 : patch PostgreSQL soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.4, 17.10, 16.14 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PostgreSQL | Affected
| Fixed in
|
| PostgreSQL | Affected
| Fixed in
|
| PostgreSQL | Affected
| Fixed in
|
| PostgreSQL | Affected
| Fixed in
|
| PostgreSQL | Affected
| Fixed in
|
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict database user privileges to the minimum necessary and avoid using user-controlled columns as "refint" cascade primary keys with user-controlled updates.
Description
CVE-2026-6637 is a high-severity stack-based buffer overflow vulnerability in the PostgreSQL database module "refint". It allows an unprivileged database user to execute arbitrary code with the privileges of the operating system user running the database. Additionally, if a user-controlled column is declared as a "refint" cascade primary key and user-controlled updates to that column are allowed, a SQL injection can enable arbitrary SQL execution as the database user. This vulnerability affects PostgreSQL versions prior to 18.4, 17.10, 16.14, 15.18, and 14.23.