CVE-2026-66400: getgrav grav · Insufficient Session Expiration
Affects getgrav gravSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 3.8.13 when convenient.
Data as of 28 Oct 2026, 05:11 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.8.13
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade getgrav grav to 3.8.13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| getgravgrav | Affected
| Fixed in
|
AI-suggested
Until an official fix or update is available, users should consider invalidating existing Remember Me cookies and monitoring for suspicious authentication activity related to persistent sessions.
Description
Grav Login Plugin versions before 3.8.13 have a vulnerability in session expiration due to improper validation of Remember Me token timestamps. This flaw allows attackers with a captured Remember Me cookie to maintain authentication indefinitely, bypassing the intended timeout. The issue arises because the expiry check compares an array to a scalar value in PHP, causing the check to always fail. The vulnerability has a medium severity rating with a CVSS score of 6.3.