Skip to main content
VulnerabilityPublished

CVE-2026-66901: CJCOLLIER Google::Auth · Server-Side Request Forgery (SSRF)

Affects CJCOLLIER Google::AuthSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 0.09 soon.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.09
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Google::Auth and Google-Auth to 0.09.

Affected software

ProductAffectedFixed in
CJCOLLIERGoogle::AuthAffected
  • <0.09
Fixed in
  • 0.09
GitHubGoogle-Authpkg:github/Google-AuthOther threatsAffected
  • <0.09
Fixed in
  • 0.09

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Google::Auth for Perl to version 0.09 or later, where URL validation and host checks have been implemented to prevent SSRF. Versions 0.06 through 0.08 introduced partial mitigations, but only 0.09 fully addresses the issue across all credential classes.

Description

CVE-2026-66901 is a server-side request forgery (SSRF) vulnerability in Google::Auth for Perl versions before 0.09. The vulnerability arises because the library does not validate URLs read from the credentials JSON, allowing attackers to cause the application to make unauthorized requests to internal or external hosts. This can lead to credential exfiltration. The issue was progressively mitigated in versions 0.06 through 0.09 by adding URL validation and host checks.

References

Community reviews

Loading reviews…