Skip to main content
VulnerabilityPublished

CVE-2026-66902: CJCOLLIER Google::Auth · OS Command Injection

Affects CJCOLLIER Google::AuthSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.06 as a priority.

Data as of 2 Nov 2026, 10:58 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.06
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Google::Auth and Google-Auth to 0.06.

Affected software

ProductAffectedFixed in
CJCOLLIERGoogle::AuthAffected
  • <0.06
Fixed in
  • 0.06
GitHubGoogle-Authpkg:github/Google-AuthOther threatsAffected
  • <0.06
Fixed in
  • 0.06

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid using untrusted or user-controlled external_account credentials JSON files that include the credential_source.executable field. Restrict access to credential files and validate or sanitize any external_account configurations before use.

Description

CVE-2026-66902 is a critical OS command injection vulnerability in Google::Auth for Perl versions before 0.06. The vulnerability arises because the Pluggable subclass executes a command specified in an external_account credentials JSON file without proper validation or gating. This command is run via a system call that passes the entire string to the shell, allowing arbitrary command execution with the privileges of the application process. The vulnerability is reachable through the standard Application Default Credentials flow when the configuration includes credential_source.executable.

References

Community reviews

Loading reviews…