CVE-2026-67324: GitPython · OS Command Injection
Affects GitPythonSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 3.1.51 as a priority.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.51
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade GitPython to 3.1.51.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| gitpython-developersGitPython | Affected
| Fixed in
|
PyPIgitpythonpkg:pypi/gitpythonOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade GitPython to version 3.1.51 or later where this vulnerability is fixed. Until then, avoid passing untrusted input to the multi_options parameter of Repo.clone_from with allow_unsafe_options set to false. Patch status is not explicitly stated but fixed version 3.1.51 is available, so upgrading is the recommended remediation.
Description
GitPython 3.1.50 fails to recognize joined short-option forms such as -u<value> (the short form of --upload-pack=<value>) when enforcing its default unsafe-option gate. When an application passes attacker-influenced clone options into Repo.clone_from(..., multi_options=..., allow_unsafe_options=False), an attacker can supply -u<helper> to bypass the gate that blocks --upload-pack/-u, causing Git to execute the specified helper command during clone. Fixed in 3.1.51.