Skip to main content
VulnerabilityPublished

CVE-2026-67399: WebPros WHMCS · Deserialization of Untrusted Data

Affects WebPros WHMCSSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 9.0.8 or 8.13.7 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.0.8, 8.13.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade WHMCS and whmcs/whmcs to 9.0.8 or 8.13.7.

Affected software

ProductAffectedFixed in
WebProsWHMCSAffected
  • >=9.0.0 <9.0.8
Fixed in
  • 9.0.8
WebProsWHMCSAffected
  • >=8.0.0 <8.13.7
Fixed in
  • 8.13.7
Packagistwhmcs/whmcspkg:composer/whmcs/whmcsOther threatsAffected
  • >=8.0.0 <8.13.7
  • >=9.0.0 <9.0.8
Fixed in
  • 8.13.7
  • 9.0.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in WHMCS versions 8.13.7 and later, and 9.0.8 and later. Users should upgrade to these versions to remediate the vulnerability. No vendor advisory content was provided, but the version ranges indicate official fixes exist in these later versions.

Description

Deserialization of untrusted data in WHMCS 9.0.0 before 9.0.8 and 8.0.0 before 8.13.7 allows remote attackers to execute arbitrary code.

References

Community reviews

Loading reviews…