Skip to main content
VulnerabilityPublished

CVE-2026-67428: flytohub flyto-core · Server-Side Request Forgery (SSRF)

Affects flytohub flyto-coreSource CVE Database V5

0

Not known to be exploited · CVSS 8.5 High : upgrade to 2.26.7 soon.

Data as of 28 Oct 2026, 05:11 UTC

CVSS 3.1 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.26.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade flyto-core and flytohub/flyto-core to 2.26.7.

Affected software

ProductAffectedFixed in
flytohubflyto-coreAffected
  • <2.26.7
Fixed in
  • 2.26.7
GitHubflytohub/flyto-corepkg:github/flytohub/flyto-coreOther threatsAffected
  • <2.26.7
Fixed in
  • 2.26.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in flyto-core version 2.26.7. Users should upgrade to version 2.26.7 or later to remediate this vulnerability. No additional mitigation guidance is provided or required beyond applying the official fix.

Description

CVE-2026-67428 is a Server-Side Request Forgery (SSRF) vulnerability in flytohub's flyto-core execution kernel for automation and AI-agent workflows. Versions prior to 2.26.7 allow HTTP-emitting modules to fetch URLs controlled by an attacker without proper validation, enabling SSRF attacks against internal or metadata endpoints. This vulnerability affects multiple modules including HTTP request handlers and notification senders. The issue is fixed in version 2.26.7.

References

Community reviews

Loading reviews…