CVE-2026-67531: agentfront frontmcp · Code Injection
Affects agentfront frontmcpSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.5.7 as a priority.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.5.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade frontmcp and agentfront/frontmcp to 1.5.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| agentfrontfrontmcp | Affected
| Fixed in
|
GitHubagentfront/frontmcppkg:github/agentfront/frontmcpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade frontmcp to version 1.5.7 or later, where this vulnerability is fixed. No other official remediation or temporary fix is documented. Until upgrading, restrict access to the vulnerable tool and avoid running untrusted scripts in the sandboxed environment.
Description
CVE-2026-67531 is a critical remote code execution vulnerability in the agentfront frontmcp framework prior to version 1.5.7. It arises from improper control of code generation due to exposure of live host Zod schema instances in sandboxed scripts. This allows an attacker to escape the sandbox and execute arbitrary code with the server user's privileges, potentially exposing sensitive secrets and credentials. The vulnerability is fixed in version 1.5.7.