CVE-2026-82393: pnpm · Path Traversal
Affects pnpmSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 11.11.0 or 10.34.5 soon.
Data as of 3 Nov 2026, 22:58 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-09-02.
- Patch
- Available – fixed in 11.11.0, 10.34.5
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 31 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade pnpm to 11.11.0 or 10.34.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pnpmpnpm | Affected
| Fixed in
|
| pnpmpnpm | Affected
| Fixed in
|
Description
pnpm is a package manager. Prior to 10.34.5 and 11.11.0, pnpm accepts a scoped path traversal in a tarball dependency's package.json manifest name because pnpm11/resolving/npm-resolver/src/pickPackage.ts rejects slash characters only for unscoped names. During pnpm install, the unvalidated name reaches raw path joins in pnpm11/installing/deps-resolver/src/resolvePeers.ts, pnpm11/installing/deps-resolver/src/index.ts, and pnpm11/deps/graph-builder/src/lockfileToDepGraph.ts, causing package extraction outside node_modules and allowing attacker-controlled files to overwrite arbitrary filesystem paths even when --ignore-scripts is used. The overwrite can replace shell startup files, Git hooks, or installed package code and lead to code execution. This issue is fixed in versions 10.34.5, and 11.11.0.
References
- github.com/pnpm/pnpm/security/advisories/GHSA-vq4v-j7r6-jq4m (opens in a new tab)
- github.com/pnpm/pnpm/pull/12872 (opens in a new tab)
- github.com/pnpm/pnpm/pull/12890 (opens in a new tab)
- github.com/pnpm/pnpm/commit/51300fd41c5e4c8f47635108e373cc3d1f324fa7 (opens in a new tab)
- github.com/pnpm/pnpm/commit/78e29fe5583a1e5d69ea05e414eff310f78d5ed9 (opens in a new tab)
- github.com/pnpm/pnpm/releases/tag/v10.34.5 (opens in a new tab)
- github.com/pnpm/pnpm/releases/tag/v11.11.0 (opens in a new tab)