Skip to main content
VulnerabilityPublished Updated

CVE-2026-68082: Linux kernel · libceph: fix two unsafe bare decodes in decode_lockers()

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-68082· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · fixed in 7.0.0-1014.14~24.04.1 : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1014.14~24.04.1, 7.0.0-1017.17~24.04.1, 7.0.0-1016.16~24.04.1 +12
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-38.38
Fixed in
  • 7.0.0-38.38
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1017.17
Fixed in
  • 7.0.0-1017.17
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1016.16
Fixed in
  • 7.0.0-1016.16
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.9
Fixed in
  • 7.0.0-1008.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected Linux Azure kernel versions to replace unsafe bare decode operations with safe variants and proper error handling. The vendor advisory confirms that updating to the fixed kernel versions resolves the issue. After applying the update, a system reboot is required. No additional mitigation actions are specified or necessary beyond applying the official fix.

Description

A vulnerability in the Linux kernel's libceph component was resolved, addressing unsafe bare decode operations in the decode_lockers() function. These unsafe decodes could allow a malicious or compromised Ceph OSD to trigger slab-out-of-bounds reads, potentially leading to memory corruption. The flaw involves missing bounds checks before decoding certain fields, which could result in out-of-bounds reads and influence over lock type fields. The issue affects Linux Azure kernel versions including 3.0 and several 4.11.x, 4.13.x, and 4.15.x builds. A patch is available that replaces unsafe decode calls with safe variants, preventing out-of-bounds reads. The vulnerability has a CVSS score of 9.8, indicating high severity. No known exploits in the wild have been reported. The vulnerability is relevant in multi-tenant Ceph deployments where a malicious OSD can trigger the flaw against kernel clients using the lock.get_info method.

References

Community reviews

Loading reviews…