CVE-2026-6841: Best Practical Request Tracker · XSS or 'Cross-site Scripting'
Affects Best Practical Request TrackerSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 6.0.3 or 5.0.10 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.0.3, 5.0.10
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 21 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Best Practical Request Tracker to 6.0.3 or 5.0.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Best PracticalRequest Tracker | Affected
| Fixed in
|
| Best PracticalRequest Tracker | Affected
| Fixed in
|
GitHubRequest Trackerpkg:github/Request TrackerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should consider applying input validation or filtering on the "Page" parameter at the application or web server level to mitigate reflected XSS risks. Additionally, educating users to avoid clicking suspicious URLs can reduce exposure.
Description
Request Tracker is vulnerable to a reflected cross-site scripting (XSS) vulnerability via the "Page" parameter in GET requests. An attacker can craft a URL that, when opened, results in arbitrary JavaScript execution in the victim’s browser. This vulnerability affects versions from 5.0.4 up to 5.0.9 and from 6.0.0 up to 6.0.2.