Skip to main content
VulnerabilityPublished

CVE-2026-69152: juliangruber brace-expansion · Uncontrolled Resource Consumption

Affects juliangruber brace-expansionSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.5 High · fixed in 5.0.9 : patch juliangruber brace-expansion soon.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.0.9, 3.0.6, 2.1.4 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade juliangruber brace-expansion to 5.0.9, 3.0.6, 2.1.4 or 1.1.18.

Affected software

ProductAffectedFixed in
juliangruberbrace-expansionAffected
  • >=4.0.0 <5.0.9
Fixed in
  • 5.0.9
juliangruberbrace-expansionAffected
  • >=3.0.0 <3.0.6
Fixed in
  • 3.0.6
juliangruberbrace-expansionAffected
  • >=2.0.0 <2.1.4
Fixed in
  • 2.1.4
juliangruberbrace-expansionAffected
  • <1.1.18
Fixed in
  • 1.1.18
npmbrace-expansionpkg:npm/brace-expansionOther threatsAffected
  • <1.1.18 >=1.0.0
  • <2.1.4 >=2.0.0
  • <3.0.6 >=3.0.0
  • <5.0.9 >=5.0.0
Fixed in
  • 1.1.18
  • 2.1.4
  • 3.0.6
  • 5.0.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in brace-expansion versions 1.1.18, 2.1.4, 3.0.6, and 5.0.9. Users should upgrade to one of these versions or later to remediate the issue. Patch status is not explicitly confirmed by a vendor advisory but the description states these versions contain the fix. Until upgraded, applications remain vulnerable.

Description

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.18, 2.1.4, 3.0.6, and 5.0.9, expand() does not apply maxLength while constructing comma-alternative intermediate arrays or padded sequences, allowing attacker-controlled input to exhaust memory or block the event loop. The fix for CVE-2026-14257 is bypassed by the vulnerability. This issue is fixed in versions 1.1.18, 2.1.4, 3.0.6, and 5.0.9.

References

Community reviews

Loading reviews…