CVE-2026-69253: FlowiseAI Flowise · Eval Injection
Affects FlowiseAI FlowiseSource CVE Database V5
Not known to be exploited · CVSS 9.0 Critical : upgrade to 3.1.3 as a priority.
Data as of 2 Nov 2026, 10:58 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.3
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Flowise and flowiseai/flowise to 3.1.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAIFlowise | Affected
| Fixed in
|
npmflowiseai/flowisepkg:npm/flowiseai/flowiseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Flowise to version 3.1.3 or later, where the vulnerability is fixed by changing how user-controlled URLs are handled in the sandbox and by adding stricter URL validation. No other mitigations are specified. Patch status is not explicitly stated but the vendor has fixed the issue in 3.1.3, so upgrading to this version or later is the recommended remediation.
Description
Flowise is a drag-and-drop user interface for building customized large language model (LLM) flows. Prior to version 3.1.3, several custom-tool components — AgentAsTool, ChatflowTool, and ExecuteFlow — ran code in the in-process vm2 sandbox. To build that code, they inserted a user-controlled baseURL value straight into the JavaScript source, for example const url = "${baseURL}/..."; . The only check on baseURL was isValidURL , but a valid-looking URL can still contain characters that break out of a code string. An authenticated user could craft a baseURL that passed this check, closed the surrounding string, and injected their own JavaScript into the sandboxed script (code injection, CWE-94). The vm2 sandbox runs in the same Node.js process as Flowise and exposes risky dependencies. As a result, the injected code could escape the sandbox and run arbitrary code on the Flowise server as the Flowise process user. Exploitation only requires an authenticated session. The issue is fixed in version 3.1.3, which passes the URL to the sandbox as data instead of inserting it into code and adds stricter URL validation.
References
- github.com/FlowiseAI/Flowise/security/advisories/GHSA-wg86-r78f-74mp (opens in a new tab)
- github.com/FlowiseAI/Flowise/pull/6417 (opens in a new tab)
- github.com/FlowiseAI/Flowise/commit/3f257bdc8196082a178da7134a075824401b13b9 (opens in a new tab)
- github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3 (opens in a new tab)