Skip to main content
VulnerabilityPublished

CVE-2026-69263: FlowiseAI Flowise · Incomplete List of Disallowed Inputs

Affects FlowiseAI FlowiseSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 3.1.3 soon.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Flowise and flowiseai/Flowise to 3.1.3.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.3
Fixed in
  • 3.1.3
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threatsAffected
  • <3.1.3
Fixed in
  • 3.1.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Flowise to version 3.1.3 or later, where this vulnerability is fixed. No other official remediation or temporary fixes are documented. Patch status is not explicitly stated but the fix is included in version 3.1.3.

Description

Flowise versions prior to 3.1.3 have an incomplete mitigation for a security issue where certain environment variables were not blocked, allowing unintended automatic package installation via npx when launching a Custom MCP server. This vulnerability is identified as CVE-2026-69263 and is fixed in version 3.1.3.

References

Community reviews

Loading reviews…