CVE-2026-6951: simple-git · Remote Code Execution (RCE)
Affects simple-gitSource CVE Database V5
Mentioned vulnerabilities
Public exploit available · CVSS 9.2 Critical : upgrade to 3.36.0 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.36.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 25 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade simple-git to 3.36.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| simple-git | Affected
| Fixed in
|
| org.webjars.npm:simple-git | Affected
| Fixed in– |
npmsimple-gitpkg:npm/simple-gitOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The Red Hat advisory does not explicitly state a fix or workaround. Users should avoid passing untrusted input to the options argument in simple-git until a fix is available.
Description
Versions of the package simple-git before 3.36.0 are vulnerable to Remote Code Execution (RCE) due to an incomplete fix for [CVE-2022-25912](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221) that blocks the -c option but not the equivalent --config form. If untrusted input can reach the options argument passed to simple-git, an attacker may still achieve remote code execution by enabling protocol.ext.allow=always and using an ext:: clone source.
References
- security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-15456078 (opens in a new tab)
- security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-16300211 (opens in a new tab)
- gist.github.com/KKC73/02d1d97f3410756095b501fda0ac8ca6 (opens in a new tab)
- github.com/steveukx/git-js/commit/89a2294febed5dfe737c4c735d936bb6018746a8 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-6951 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2461750 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-6951.json (opens in a new tab)