Skip to main content
VulnerabilityPublished

CVE-2026-6970: Canonical authd · Placement of User Into Incorrect Group

Affects Canonical authdSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.3 High : upgrade to 0.6.4 or 0.6.1ubuntu0.1 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.4, 0.6.1ubuntu0.1
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Canonical authd to 0.6.4 or 0.6.1ubuntu0.1.

Affected software

ProductAffectedFixed in
CanonicalauthdAffected
  • >=0.6.0 <0.6.4
Fixed in
  • 0.6.4
CanonicalauthdAffected
  • >=0.6.1 <0.6.1ubuntu0.1
Fixed in
  • 0.6.1ubuntu0.1
GitHubcanonical/authdpkg:github/canonical/authdOther threatsAffected
  • =0.6.0
  • =0.6.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid using affected versions 0.6.0 and 0.6.1 of authd in environments where this vulnerability could be exploited. Review user group assignments and avoid manual changes to primary group IDs that could trigger this issue.

Description

authd prior to version 0.6.4 contains a logic error in primary group ID assignment that can lead to local privilege escalation. When a user's primary group ID (GID) differs from their UID, either because the account was created with authd prior to version 0.5.4 or because the primary group was manually changed via the `authctl group set-gid` command, and the user's identity provider record is updated, authd incorrectly resets the user's primary group ID to their UID upon next login. This causes newly created files and directories to be owned by the wrong group, causing denial of service issues, and potentially granting unintended access to other local users and allowing local privilege escalation.

References

Community reviews

Loading reviews…