CVE-2026-7014: MaxSite CMS · Cross-site Scripting
Affects MaxSite CMSSource CVE Database V5
Public exploit available · CVSS 4.8 Medium.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 26 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MaxSiteCMS | Affected
| Fixed in– |
GitHubmaxsite/cmspkg:github/maxsite/cmsOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade MaxSite CMS to version 109.4 or later, where the vulnerability has been fixed by adding htmlspecialchars() filtering to the affected parameters. This official fix prevents the injection of malicious scripts and incorrect data display. Since the vendor has deployed this countermeasure, no additional action is required beyond applying the update.
Description
A flaw has been found in MaxSite CMS up to 109.3. This vulnerability affects unknown code of the component down_count Plugin. This manipulation of the argument f_file/f_prefix causes cross site scripting. The attack may be initiated remotely. The exploit has been published and may be used. Upgrading to version 109.4 is able to resolve this issue. Patch name: 8a3946bd0a54bfb72a4d57179fcd253f2c550cd7. The affected component should be upgraded. The vendor was informed early about this issue. They classify it as a "Self-XSS". They deployed a countermeasure: "Nevertheless, we consider this a violation of secure coding standards. The lack of filtering via `htmlspecialchars()` has already been fixed in the latest patch to prevent incorrect data display."
References
- vuldb.com/vuln/359594 (opens in a new tab)
- vuldb.com/vuln/359594/cti (opens in a new tab)
- vuldb.com/submit/796739 (opens in a new tab)
- github.com/wnaspy/CVE/blob/main/Report-%20Stored%20XSS-in-down_count-plugin-maxsite-cms.pdf.pdf (opens in a new tab)
- github.com/maxsite/cms/commit/8a3946bd0a54bfb72a4d57179fcd253f2c550cd7 (opens in a new tab)
- github.com/maxsite/cms/releases/tag/v109 (opens in a new tab)
- github.com/maxsite/cms/ (opens in a new tab)