Skip to main content
VulnerabilityPublished Updated

CVE-2026-7015: MaxSite CMS · Cross-site Scripting

Affects MaxSite CMSSource CVE Database V5

0
Compare

Public exploit available · CVSS 4.8 Medium · fixed in 109.4 : patch MaxSite CMS as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 109.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
MaxSiteCMSAffected
  • 109.0 – 109.3
4 affected builds
Fixed in–
GitHubmaxsite/cmspkg:github/maxsite/cmsOther threatsAffected
  • 109.0 – 109.3
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in MaxSite CMS version 109.4, which includes proper filtering of input via htmlspecialchars() to prevent XSS. It is recommended to upgrade affected installations to version 109.4 to remediate this vulnerability. Since the vendor has deployed this official fix, no additional mitigation steps are necessary.

Description

A vulnerability has been found in MaxSite CMS up to 109.3. This issue affects some unknown processing of the component Guestbook Plugin. Such manipulation of the argument f_text/f_slug/f_limit/f_email leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 109.4 is capable of addressing this issue. The name of the patch is 8a3946bd0a54bfb72a4d57179fcd253f2c550cd7. It is suggested to upgrade the affected component. The vendor was informed early about this issue. They classify it as a "Self-XSS". They deployed a countermeasure: "Nevertheless, we consider this a violation of secure coding standards. The lack of filtering via `htmlspecialchars()` has already been fixed in the latest patch to prevent incorrect data display."

References

Community reviews

Loading reviews…