CVE-2026-71198: OpenStack Glance · Server-Side Request Forgery (SSRF)
Affects OpenStack GlanceSource CVE Database V5
Not known to be exploited · CVSS 7.0 High · fixed in 32.0.1 : patch OpenStack Glance soon.
Data as of 29 Oct 2026, 10:37 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 32.0.1, 31.1.1, 30.2.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade OpenStack Glance to 32.0.1, 31.1.1 or 30.2.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenStackGlance | Affected
| Fixed in
|
| OpenStackGlance | Affected
| Fixed in
|
| OpenStackGlance | Affected
| Fixed in
|
AI-suggested
A fix is available in OpenStack Glance version 32.0.1 and later. Users should upgrade affected deployments to version 32.0.1 or newer to remediate this vulnerability. Until upgraded, restrict access to the location API to trusted users only and consider disabling the HTTP store backend if feasible. Patch status is confirmed by the version ranges indicating fixed versions. No vendor advisory content was provided, so check the official OpenStack security advisories for the latest remediation guidance.
Description
CVE-2026-71198 is a server-side request forgery (SSRF) vulnerability in OpenStack Glance before version 32.0.1. The flaw exists in the location API, which fails to validate destination hosts when adding an HTTP location to an image. This allows an authenticated user to add locations pointing to internal endpoints such as the cloud metadata service and retrieve data by downloading the image. Both the new POST /v2/images/{id}/locations API and the old PATCH API (when show_multiple_locations is enabled) are affected. Deployments using the HTTP store backend are vulnerable.