Skip to main content
VulnerabilityPublished

CVE-2026-71436: mermaid · Infinite Loop

Affects mermaidSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 11.16.1 or 10.9.8 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.16.1, 10.9.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade mermaid to 11.16.1 or 10.9.8; mermaid-js/mermaid to 10.9.8.

Affected software

ProductAffectedFixed in
mermaid-jsmermaidAffected
  • >=11.0.0-alpha.1 <11.16.1
Fixed in
  • 11.16.1
mermaid-jsmermaidAffected
  • >=10.6.0 <10.9.8
Fixed in
  • 10.9.8
npmmermaid-js/mermaidpkg:npm/mermaid-js/mermaidOther threatsAffected
  • >=10.6.0 <10.9.8
  • =11.16.0
Fixed in
  • 10.9.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in mermaid-js versions 10.9.8 and 11.16.1. Users should upgrade to these or later versions to remediate the issue. No vendor advisory states otherwise, so patching is the recommended mitigation.

Description

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. From version 10.6.0 until 10.9.8 and 11.16.1, Mermaid XY Charts are vulnerable to an infinite loop denial of service in the setXAxisRangeData function when configuring an X-Axis with invalid parameters. Because each loop iteration appends an element to an array, this generally causes a RangeError to appear after a few seconds, but it may instead cause the page or JavaScript process to crash from memory exhaustion, depending on the environment. This issue is fixed in versions 10.9.8 and 11.16.1.

References

Community reviews

Loading reviews…