Skip to main content
VulnerabilityPublished

CVE-2026-7191: QnABot on AWS · Code Injection

Affects QnABot on AWSSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 7.3.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.3.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade static-eval to 7.3.0.

Affected software

ProductAffectedFixed in
AWSQnABot on AWSAffected
  • <=7.2.4
Fixed in–
npmstatic-evalpkg:npm/static-evalOther threatsAffected
  • <7.3.0
Fixed in
  • 7.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

AWS has released a fixed version 7.3.0 of QnABot on AWS that addresses this vulnerability. Users should upgrade to version 7.3.0 or later to remediate the issue. Since this is a cloud-hosted service, AWS manages remediation for the cloud environment, but customers must update their deployed QnABot versions accordingly. No alternative mitigations are specified in the advisory.

Description

CVE-2026-7191 is a high-severity vulnerability in AWS QnABot on AWS versions up to 7.2.4. It involves improper control of code generation due to unsafe use of the static-eval npm package. An authenticated administrator can inject crafted expressions via the Content Designer interface to execute arbitrary code in the Lambda fulfillment environment, potentially accessing backend resources like environment variables, OpenSearch indices, S3 objects, and DynamoDB tables. AWS recommends upgrading to version 7.3.0 or later to remediate this issue.

References

Community reviews

Loading reviews…