CVE-2026-7195: Progress Software Sitefinity · Improper Input Validation
Affects Progress Software SitefinitySource CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 15.4.8630 : patch Progress Software Sitefinity soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 15.4.8630, 15.3.8531, 15.2.8441 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Progress SoftwareSitefinity | Affected
| Fixed in
|
| Progress SoftwareSitefinity | Affected
| Fixed in
|
| Progress SoftwareSitefinity | Affected
| Fixed in
|
| Progress SoftwareSitefinity | Affected
| Fixed in
|
| Progress SoftwareSitefinity | Affected
| Fixed in
|
| Progress SoftwareSitefinity | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, consider reviewing site configurations to ensure minimal exposure and limit user interaction vectors where possible.
Description
CWE-20: Improper Input Validation in web services in Progress Sitefinity 14.1.x through 14.3.x, 14.4.x before 14.4.8152, 15.0.x before 15.0.8234, 15.1.x before 15.1.8335, 15.2.x before 15.2.8441, 15.3.x before 15.3.8531, and 15.4.x before 15.4.8630 allows a remote unauthenticated attacker to compromise the integrity and confidentiality of user accounts. Successful exploitation requires user interaction and a non-default site configuration.