CVE-2026-72329: Linux kernel · net/liquidio: drop cached VF pci_dev LUT
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 9.3 Critical · fixed in 7.0.0-1013.13~24.04.1 : patch Linux kernel as a priority.
Data as of 28 Oct 2026, 02:48 UTC
- Patch
- Available – fixed in 7.0.0-1013.13~24.04.1, 7.0.0-1017.17~24.04.1, 7.0.0-1016.16~24.04.1 +13
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-8781-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8816-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8816-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8816-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8816-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8888-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8888-2 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied immediately. The vulnerability is fixed in Linux kernel versions 7.0.0-1013.13 and later, as well as other specified fixed versions. Users should update their systems to these fixed kernel versions as provided by their Linux distribution vendor. After updating, a system reboot is required to apply the kernel update. Due to ABI changes, recompilation and reinstallation of third-party kernel modules may be necessary. No other mitigations are specified or required beyond applying the official patches.
Description
CVE-2026-72329 is a critical vulnerability in the Linux kernel's net/liquidio driver related to improper caching of virtual function (VF) PCI device pointers. The flaw involves caching VF pci_dev pointers without owning proper references, leading to potential use-after-free conditions when handling VF function level resets. This vulnerability has been fixed by replacing cached VF mappings with runtime lookups and proper reference management. The issue affects multiple Linux kernel versions, including various Ubuntu kernel releases prior to 7.0.0-1013.13 and specific 4.11 and 4.13 kernel builds. A patch is available and should be applied promptly.
References
- ubuntu.com/security/CVE-2026-72329 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-72329 (opens in a new tab)
- git.kernel.org/linus/5c0e3ba4f500fd4314ceb42f07f16bc445156431 (opens in a new tab)
- git.kernel.org/stable/c/5c0e3ba4f500fd4314ceb42f07f16bc445156431 (opens in a new tab)
- git.kernel.org/stable/c/81acef3a247fd523513a2e9f71de1c167bc0f882 (opens in a new tab)
- ubuntu.com/security/notices/USN-8781-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8816-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8816-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8816-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8816-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8888-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8888-2 (opens in a new tab)