Skip to main content
VulnerabilityPublished Updated

CVE-2026-72412: Linux kernel · s390/mm: Fix handling of _PAGE_UNUSED pte bit

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 9.3 Critical · fixed in 7.0.0-1013.13~24.04.1 : patch Linux kernel as a priority.

Data as of 28 Oct 2026, 02:46 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.0.0-1013.13~24.04.1, 7.0.0-1017.17~24.04.1, 7.0.0-1016.16~24.04.1 +12
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-34.34
Fixed in
  • 7.0.0-34.34
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1013.13
Fixed in
  • 7.0.0-1013.13
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1017.17
Fixed in
  • 7.0.0-1017.17
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1016.16
Fixed in
  • 7.0.0-1016.16
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1013.13
Fixed in
  • 7.0.0-1013.13
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1007.8
Fixed in
  • 7.0.0-1007.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in Linux kernel versions 7.0.0-1013.13~24.04.1 and later. Users should update their Linux kernel to these fixed versions or later to remediate the vulnerability. After updating, a system reboot is required to apply the changes. Additionally, due to an ABI change, recompilation and reinstallation of any third-party kernel modules are necessary. No other mitigation actions are indicated by the vendor advisory.

Description

CVE-2026-72412 is a critical vulnerability in the Linux kernel's s390 architecture memory management subsystem. It involves improper handling of the _PAGE_UNUSED page table entry (pte) bit, which signals that a page can be discarded rather than moved or swapped. Due to incomplete clearing of this bit when pages are reused, used pages could be mistakenly discarded, leading to guest system corruption in virtualized environments. The issue has been fixed by ensuring the _PAGE_UNUSED bit is cleared whenever a present pte is set.

References

Community reviews

Loading reviews…