CVE-2026-73192: Apache Sling XSS · Cross-site Scripting
Affects Apache Sling XSSSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 2.4.12 when convenient.
Data as of 6 Nov 2026, 23:24 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.12
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade Apache Sling XSS and org.apache.sling/org.apache.sling.xss to 2.4.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Sling XSS | Affected
| Fixed in
|
Mavenorg.apache.sling/org.apache.sling.xsspkg:maven/org.apache.sling/org.apache.sling.xssOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache Sling XSS to version 2.4.12 or later, where this vulnerability is fixed. No other mitigations are specified or required once the upgrade is applied.
Description
An improper neutralization of input during web page generation ('Cross-site Scripting') [CWE-79] vulnerability when using the XSSAPI.getValidHref() in Apache Sling XSS version 2.4.10 and prior may allow an attacker to perform a reflected cross-site scripting (XSS) attack in every feature using this method. In order to successfully attack an application, the attacker needs to be able to submit a value which is not correctly sanitized by that library. Upgrade to Apache Sling XSS >= 2.4.12