CVE-2026-91852: Apache Sling XSS · Cross-site Scripting
Affects Apache Sling XSSSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 2.4.12 when convenient.
Data as of 6 Nov 2026, 23:24 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.12
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade Apache Sling XSS and org.apache.sling/xss to 2.4.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Sling XSS | Affected
| Fixed in
|
Mavenorg.apache.sling/xsspkg:maven/org.apache.sling/xssOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Sling XSS to version 2.4.12 or later, where this vulnerability has been fixed. No other mitigation actions are specified or required.
Description
Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Sling XSS. This issue affects Apache Sling XSS: before 2.4.12. Users are recommended to upgrade to version 2.4.12, which fixes the issue.