Skip to main content
VulnerabilityPublished

CVE-2026-73549: envoyproxy envoy · Unchecked Error Condition

Affects envoyproxy envoySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium · fixed in 1.39.1 : update envoyproxy envoy when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.39.1, 1.38.4, 1.37.6 +1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade envoy and envoyproxy/envoy to 1.39.1, 1.38.4, 1.37.6 or 1.36.10.

Affected software

ProductAffectedFixed in
envoyproxyenvoyAffected
  • >=1.39.0 <1.39.1
Fixed in
  • 1.39.1
envoyproxyenvoyAffected
  • >=1.38.0 <1.38.4
Fixed in
  • 1.38.4
envoyproxyenvoyAffected
  • >=1.37.0 <1.37.6
Fixed in
  • 1.37.6
envoyproxyenvoyAffected
  • <1.36.10
Fixed in
  • 1.36.10
GitHubenvoyproxy/envoypkg:github/envoyproxy/envoyOther threatsAffected
  • <1.36.10
  • >=1.37.0 <1.37.6
  • >=1.38.0 <1.38.4
  • >=1.39.0 <1.39.1
Fixed in
  • 1.36.10
  • 1.37.6
  • 1.38.4
  • 1.39.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Envoy versions 1.36.10, 1.37.6, 1.38.4, and 1.39.1. Users should upgrade to one of these versions or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-73549 is a medium severity vulnerability in Envoy proxy prior to versions 1.36.10, 1.37.6, 1.38.4, and 1.39.1. It involves improper handling of scoped IPv6 addresses in certain network paths, which can cause the process to terminate unexpectedly due to exceptions or aborts. This affects deployments using kernel-provided scoped IPv6 destinations in ORIGINAL_DST transparent-proxy setups and certain QUIC connection paths. The issue is fixed in the specified versions.

References

Community reviews

Loading reviews…