CVE-2026-7505: nextlevelbuilder GoClaw · Improper Authorization
Affects nextlevelbuilder GoClawSource CVE Database V5
Public exploit available · CVSS 6.9 Medium · fixed in 3.9.0 : patch nextlevelbuilder GoClaw as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.9.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 30 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nextlevelbuilderGoClaw | Affected
| Fixed in– |
| nextlevelbuilderGoClaw Lite | Affected
| Fixed in– |
Gogithub.com/nextlevelbuilder/goclawpkg:golang/github.com/nextlevelbuilder/goclawOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected installations of nextlevelbuilder GoClaw and GoClaw Lite to version 3.9.0, which contains the fix for this improper authorization vulnerability. No other official remediation or temporary fixes are documented. Patch status is confirmed by the vendor's release of version 3.9.0.
Description
CVE-2026-7505 is an improper authorization vulnerability in nextlevelbuilder GoClaw and GoClaw Lite versions up to 3.8.5. The flaw exists in an unknown function within the RPC Handler component and can be exploited remotely without authentication. Exploit code has been published. Upgrading to version 3.9.0 mitigates the issue.
References
- vuldb.com/vuln/360314 (opens in a new tab)
- vuldb.com/vuln/360314/cti (opens in a new tab)
- vuldb.com/submit/803458 (opens in a new tab)
- github.com/nextlevelbuilder/goclaw/issues/866 (opens in a new tab)
- github.com/nextlevelbuilder/goclaw/pull/950 (opens in a new tab)
- github.com/nextlevelbuilder/goclaw/commit/406022e79f4a18b3070a446712080571eff11e30 (opens in a new tab)
- github.com/nextlevelbuilder/goclaw/releases/tag/v3.9.0 (opens in a new tab)
- github.com/nextlevelbuilder/goclaw/ (opens in a new tab)