Skip to main content
VulnerabilityPublished Updated

CVE-2026-75158: Apache Airflow · Information Exposure

Affects Apache AirflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.3 Medium : upgrade to 3.0.0 when convenient.

Data as of 5 Nov 2026, 11:40 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.14.3
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.0, 3.3.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Apache Airflow and apache-airflow to 3.0.0; Apache Airflow and apache-airflow and apache-airflow-core to 3.3.2.

Affected software

ProductAffectedFixed in
Apache Airflowapache-airflowAffected
  • <3.0.0
Fixed in
  • 3.0.0
Apache Airflowapache-airflow-coreAffected
  • >=3.0.0 <3.3.2
Fixed in
  • 3.3.2
PyPIapache-airflowpkg:pypi/apache-airflowOther threatsAffected
  • <3.3.2
Fixed in
  • 3.3.2
PyPIapache-airflowpkg:pypi/apache-airflowOther threatsAffected
  • <3.0.0
Fixed in
  • 3.0.0
PyPIapache-airflow-corepkg:pypi/apache-airflow-coreOther threatsAffected
  • >=3.0.0 <3.3.2
Fixed in
  • 3.3.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Airflow to version 3.3.2 or later, where this vulnerability is fixed. No special configuration is required to mitigate the issue beyond applying the official patch. Deployments using per-DAG access control should prioritize this update to prevent unauthorized information disclosure.

Description

Apache Airflow versions prior to 3.3.2 have an information exposure vulnerability in the /assets/events API. Authenticated users with asset-read access can enumerate asset events for all DAGs, including those they are not authorized to view, due to missing access control filters. This exposure includes sensitive metadata such as source DAG ID, task ID, run ID, and event timestamps. Pagination and total entry counts also reveal the existence of hidden DAGs. This affects deployments using per-DAG access control without requiring special configuration. The issue is fixed in Apache Airflow 3.3.2 and later.

References

Community reviews

Loading reviews…