CVE-2026-75595: netty · Unchecked Error Condition
Affects nettySource GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.2.17.Final or 4.1.137.Final as a priority.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.17.Final, 4.1.137.Final
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 19 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade netty to 4.2.17.Final or 4.1.137.Final.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| netty netty | Affected
| Fixed in
|
Description
Netty is an asynchronous, event-driven network application framework. Prior to 4.1.137.Fina and 4.2.17.Final, io.netty.handler.ssl.SslClientHelloHandler#decode checks the wrong offset before reading the four-byte TLS handshake header, so a ClientHello whose handshake header spans records can cause an IndexOutOfBoundsException and invoke select(ctx, null). This selects the default SslContext instead of the SNI-specific context. In deployments where per-SNI clientAuth=REQUIRE is the sole mutual TLS gate, the default SslContext uses clientAuth=NONE or clientAuth=OPTIONAL, and no application-layer certificate verification exists, an unauthenticated remote attacker can bypass the protected route's mutual TLS requirement. This issue is fixed in versions 4.1.137.Final and 4.2.17.Final.
References
- github.com/netty/netty/security/advisories/GHSA-c4c3-7fpv-j4q5 (opens in a new tab)
- github.com/netty/netty/pull/17213 (opens in a new tab)
- github.com/netty/netty/pull/17217 (opens in a new tab)
- github.com/netty/netty/commit/1b5abc6443b63726c72cdd285af2feb7ddbb8ff7 (opens in a new tab)
- github.com/netty/netty/commit/9e0519239108a69b7e9bbc5e9182ee139a0d7961 (opens in a new tab)
- github.com/netty/netty/releases/tag/netty-4.1.137.Final (opens in a new tab)
- github.com/netty/netty/releases/tag/netty-4.2.17.Final (opens in a new tab)