CVE-2026-75893: Osmocom osmo-bsc · Heap-based Buffer Overflow
Affects Osmocom osmo-bscSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 1.14.1 soon.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.14.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Osmocom osmo-bsc to 1.14.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Osmocomosmo-bsc | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, cautious handling of IPA frame inputs and monitoring for crashes is advisable.
Description
A heap-based buffer overflow vulnerability exists in the osmo-bsc component of Osmocom in versions from 1.0.1 up to but not including 1.14.1. The flaw is located in the ipaccess_proxy_read_msg() function and is triggered by malformed IPA frame lengths. This vulnerability can cause a denial of service by crashing the application but does not impact confidentiality or integrity.