CVE-2026-76183: Apache Tomcat · Authentication Bypass by Alternate Name
Affects Apache TomcatSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 7.0.43 as a priority.
Data as of 6 Nov 2026, 23:24 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.43
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade org.apache.tomcat/tomcat to 7.0.43.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Tomcat | Affected
| Fixed in– |
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade affected Apache Tomcat installations to versions 11.0.26, 10.1.60, or 9.0.122 or later, where the vulnerability is fixed. No other mitigation or temporary workaround is indicated in the advisory. Applying the official fix is the recommended remediation.
Description
CVE-2026-76183 is a critical authentication bypass vulnerability in Apache Tomcat affecting multiple versions from 7.0.43 through 11.0.25. It allows bypassing security constraints on WebSocket endpoints, potentially enabling unauthorized access. The issue is fixed in Apache Tomcat versions 11.0.26, 10.1.60, and 9.0.122. Users should upgrade to these versions to mitigate the risk.