Skip to main content
VulnerabilityPublished

CVE-2026-76805: projectdiscovery nuclei · Information Exposure

Affects projectdiscovery nucleiSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.10.0 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.10.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade nuclei and projectdiscovery/nuclei to 3.10.0.

Affected software

ProductAffectedFixed in
projectdiscoverynucleiAffected
  • >=3.0.0 <3.10.0
Fixed in
  • 3.10.0
GitHubprojectdiscovery/nucleipkg:github/projectdiscovery/nucleiOther threatsAffected
  • >=3.0.0 <3.10.0
Fixed in
  • 3.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Nuclei to version 3.10.0 or later, where this vulnerability is fixed. Users who do not enable the -env-vars option are not affected by this issue. No other mitigation is required.

Description

Nuclei versions from 3.0.0 up to but not including 3.10.0 contain a vulnerability where response content captured during a scan can be re-evaluated as template syntax, potentially exposing sensitive environment variables. This occurs when the -env-vars option is enabled and a multi-step DAST or fuzz template reuses response data. The issue is fixed in version 3.10.0.

References

Community reviews

Loading reviews…