Skip to main content
VulnerabilityPublished

CVE-2026-76894: ondata ckan-mcp-server · Insufficient Verification of Data Authenticity

Affects ondata ckan-mcp-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.1 Low : upgrade to 0.4.112 when convenient.

Data as of 3 Nov 2026, 20:59 UTC

CVSS 3.1 base score
3.1Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.13.1
Patch
Available – fixed in 0.4.112
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade ckan-mcp-server and ondata/ckan-mcp-server to 0.4.112.

Affected software

ProductAffectedFixed in
ondatackan-mcp-serverAffected
  • <0.4.112
Fixed in
  • 0.4.112
GitHubondata/ckan-mcp-serverpkg:github/ondata/ckan-mcp-serverOther threatsAffected
  • <0.4.112
Fixed in
  • 0.4.112

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to version 0.4.112 or later, where the issue is fixed by properly validating event.origin and restricting the target origin in postMessage calls. No additional mitigation is required once the software is updated.

Description

CVE-2026-76894 is a vulnerability in the ondata ckan-mcp-server prior to version 0.4.112. It involves insufficient verification of data authenticity in the DataStore table UI, which accepts window message events without validating the event origin and uses a wildcard target origin in postMessage calls. This can allow a malicious frame that can reach the embedded document to inject fabricated fields or records, spoof UI initialization responses, disrupt the UI handshake, or receive outbound messages when embedded by an untrusted parent. The vulnerability results in display spoofing rather than script execution due to HTML escaping of values. The issue is fixed in version 0.4.112.

References

Community reviews

Loading reviews…