CVE-2026-7722: PrefectHQ prefect · Improper Authentication
Affects PrefectHQ prefectSource CVE Database V5
Public exploit available · CVSS 6.9 Medium · fixed in 3.6.22 : patch PrefectHQ prefect as a priority.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.6.22
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PrefectHQprefect | Affected
| Fixed in– |
PyPIprefectpkg:pypi/prefectOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:prefect:prefect:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade PrefectHQ prefect to version 3.6.22 or later to remediate this vulnerability. Since the vendor has released a fixed version, applying this official update is the recommended mitigation. Patch status is confirmed by the advisory stating upgrading to 3.6.22 fixes the issue.
Description
A vulnerability was detected in PrefectHQ prefect up to 3.6.21. This impacts the function endswith of the file /api/health of the component Health Check API. Performing a manipulation results in improper authentication. The attack is possible to be carried out remotely. The exploit is now public and may be used. Upgrading to version 3.6.22 will fix this issue. The patch is named e21617125335025b4b27e7d6f0ca028e8e8f3b79. Upgrading the affected component is recommended. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
References
- vuldb.com/vuln/360898 (opens in a new tab)
- vuldb.com/vuln/360898/cti (opens in a new tab)
- vuldb.com/submit/807255 (opens in a new tab)
- gist.github.com/nedlir/f576abbb0e491dc9bb7e106c140dda04 (opens in a new tab)
- github.com/PrefectHQ/prefect/pull/21063 (opens in a new tab)
- github.com/PrefectHQ/prefect/commit/e21617125335025b4b27e7d6f0ca028e8e8f3b79 (opens in a new tab)
- github.com/PrefectHQ/prefect/releases/tag/3.6.22 (opens in a new tab)
- github.com/PrefectHQ/prefect/ (opens in a new tab)