CVE-2026-7723: PrefectHQ prefect · Missing Authentication
Affects PrefectHQ prefectSource CVE Database V5
Public exploit available · CVSS 6.9 Medium.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PrefectHQprefect | Affected
| Fixed in– |
PyPIprefectpkg:pypi/prefectOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:prefect:prefect:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available by upgrading PrefectHQ prefect to version 3.6.14, which includes the patch identified by commit 0d3ab3c2d3f9f98abfafdf7b9f6d4f8ed3925e40. Users of affected versions (3.6.0 through 3.6.13) are strongly recommended to upgrade to this version to remediate the missing authentication issue. No other mitigation or temporary workaround is indicated.
Description
A flaw has been found in PrefectHQ prefect up to 3.6.13. Affected is an unknown function of the file /api/events/in of the component WebSocket Endpoint. Executing a manipulation can lead to missing authentication. The attack may be performed from remote. The exploit has been published and may be used. Upgrading to version 3.6.14 is able to address this issue. This patch is called f8afecadf88ea5f73694dafa3a365b9d8fae1ad6. It is recommended to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
References
- vuldb.com/vuln/360899 (opens in a new tab)
- vuldb.com/vuln/360899/cti (opens in a new tab)
- vuldb.com/submit/807256 (opens in a new tab)
- gist.github.com/nedlir/f1ab8aa038aafbcc6beeef21fab1d74f (opens in a new tab)
- github.com/PrefectHQ/prefect/pull/20372 (opens in a new tab)
- github.com/PrefectHQ/prefect/commit/f8afecadf88ea5f73694dafa3a365b9d8fae1ad6 (opens in a new tab)
- github.com/PrefectHQ/prefect/releases/tag/3.6.14 (opens in a new tab)
- github.com/PrefectHQ/prefect/ (opens in a new tab)