Skip to main content
VulnerabilityPublished

CVE-2026-77281: caddyserver caddy · Code Injection

Affects caddyserver caddySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.11.4 when convenient.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.11.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade caddy and caddyserver/caddy to 2.11.4.

Affected software

ProductAffectedFixed in
caddyservercaddyAffected
  • <2.11.4
Fixed in
  • 2.11.4
GitHubcaddyserver/caddypkg:github/caddyserver/caddyOther threatsAffected
  • <2.11.4
Fixed in
  • 2.11.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in caddyserver caddy version 2.11.4. Users should upgrade to version 2.11.4 or later to remediate this vulnerability.

Description

CVE-2026-77281 is a medium severity vulnerability in caddyserver caddy versions prior to 2.11.4. It involves improper control of code generation (code injection) in the rewrite handler and placeholder layer. Specifically, when a rewrite URI ends with a literal question mark, attacker-controlled replacement bytes can be passed through a second placeholder expansion, potentially disclosing environment or request-variable data and readable files if the file provider module is registered. This issue is fixed in version 2.11.4.

References

Community reviews

Loading reviews…