Skip to main content
VulnerabilityPublished

CVE-2026-45135: caddyserver caddy · Improper Input Validation

Affects caddyserver caddySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 2.11.3 soon.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.11.3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade caddy and caddyserver/caddy to 2.11.3.

Affected software

ProductAffectedFixed in
caddyservercaddyAffected
  • >=2.7.0 <2.11.3
Fixed in
  • 2.11.3
GitHubcaddyserver/caddypkg:github/caddyserver/caddyOther threatsAffected
  • >=2.7.0 <2.11.3
Fixed in
  • 2.11.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the vulnerability is fixed in Caddy version 2.11.3. Users should upgrade to version 2.11.3 or later to remediate this issue. Since this is a cloud-hosted service, the vendor manages remediation for the cloud service; users should verify with the vendor that their cloud instances are updated. No additional mitigations are specified by the vendor advisory.

Description

Caddy is an extensible server platform that uses TLS by default. From 2.7.0 until 2.11.3, the FastCGI transport's splitPos() in modules/caddyhttp/reverseproxy/fastcgi/fastcgi.go misuses golang.org/x/text/search with search.IgnoreCase when the request path contains a non-ASCII byte. Two distinct flaws in that fallback let an attacker mislead Caddy's FastCGI splitting into treating a non-.php (or other configured split_path extension) file as a script. In any deployment where the attacker can place content into a file served via FastCGI (uploads, file storage, etc.), this can be escalated to remote code execution by crafting a URL whose path triggers either flaw. This vulnerability is fixed in 2.11.3.

References

Community reviews

Loading reviews…