CVE-2026-7735: osrg GoBGP · Buffer Overflow
Affects osrg GoBGPSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:XExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| osrgGoBGP | Affected
| Fixed in– |
Gogithub.com/osrg/gobgppkg:golang/github.com/osrg/gobgpOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:osrg:gobgp:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected GoBGP installations to version 4.4.0 or later, which contains the official patch (commit 51ad1ada06cb41ce47b7066799981816f50b7ced) addressing this buffer overflow vulnerability. Since this is a self-hosted software component, users must apply the update manually. Patch status is confirmed by the vendor's versioning and patch commit. No additional mitigations are specified.
Description
A vulnerability was found in osrg GoBGP up to 4.3.0. Affected is the function PathAttributeAigp.DecodeFromBytes of the file pkg/packet/bgp/bgp.go of the component AIGP Attribute Parser. Performing a manipulation results in buffer overflow. It is possible to initiate the attack remotely. Upgrading to version 4.4.0 is able to address this issue. The patch is named 51ad1ada06cb41ce47b7066799981816f50b7ced. The affected component should be upgraded.
References
- vuldb.com/vuln/360910 (opens in a new tab)
- vuldb.com/vuln/360910/cti (opens in a new tab)
- vuldb.com/submit/807600 (opens in a new tab)
- github.com/osrg/gobgp/commit/51ad1ada06cb41ce47b7066799981816f50b7ced (opens in a new tab)
- github.com/osrg/gobgp/releases/tag/v4.4.0 (opens in a new tab)
- github.com/osrg/gobgp/ (opens in a new tab)