CVE-2026-77404: rabbitmq amqp091-go · Improper Encoding or Escaping of Output
Affects rabbitmq amqp091-goSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 1.13.0 soon.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.13.0
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade amqp091-go and github.com/rabbitmq/amqp091-go to 1.13.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rabbitmqamqp091-go | Affected
| Fixed in
|
Gogithub.com/rabbitmq/amqp091-gopkg:golang/github.com/rabbitmq/amqp091-goOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to RabbitMQ amqp091-go version 1.13.0 or later, where this issue is fixed by properly encoding TLS asset paths as URL query parameters. No other mitigation is indicated by the vendor advisory.
Description
CVE-2026-77404 is a high-severity vulnerability in the RabbitMQ amqp091-go client prior to version 1.13.0. The issue arises because the URI.String function concatenates TLS asset paths directly into the AMQPS query string without proper URL encoding. This improper encoding can allow embedded delimiters in TLS asset paths to alter or overwrite connection options when the URI is reparsed, potentially corrupting connection configuration or causing unintended cryptographic assets to be selected. The vulnerability is fixed in version 1.13.0.
References
- github.com/rabbitmq/amqp091-go/security/advisories/GHSA-465g-fh3v-9jw4 (opens in a new tab)
- github.com/rabbitmq/amqp091-go/pull/352 (opens in a new tab)
- github.com/rabbitmq/amqp091-go/commit/743d488e46955fe7ffc55506fe2c401d01216783 (opens in a new tab)
- github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0 (opens in a new tab)