CVE-2026-77405: rabbitmq amqp091-go · Inadequate Encryption Strength
Affects rabbitmq amqp091-goSource CVE Database V5
Not known to be exploited · CVSS 9.4 Critical : upgrade to 1.13.0 as a priority.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.13.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade amqp091-go and github.com/rabbitmq/amqp091-go to 1.13.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rabbitmqamqp091-go | Affected
| Fixed in
|
Gogithub.com/rabbitmq/amqp091-gopkg:golang/github.com/rabbitmq/amqp091-goOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the amqp091-go client to version 1.13.0 or later, where the minimum TLS version is explicitly set to TLS 1.2, preventing negotiation of obsolete TLS protocols. If upgrading is not immediately possible, ensure that the Go runtime used enforces a minimum TLS version of 1.2 or higher. No other mitigations are specified.
Description
RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.
References
- github.com/rabbitmq/amqp091-go/security/advisories/GHSA-33mj-cw25-m34h (opens in a new tab)
- github.com/rabbitmq/amqp091-go/pull/355 (opens in a new tab)
- github.com/rabbitmq/amqp091-go/commit/c9fd433ecac2e557919e51acc9d809390c402c6e (opens in a new tab)
- github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0 (opens in a new tab)